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Introduction 
 
This document provides development guidelines for VR accessory makers and content 
developers interested in VIVE Wrist Tracker. These guidelines describe how to use VIVE Wrist 
Tracker for position tracking and data transmission. 
 
When paired with VIVE Focus 3, VIVE Wrist Tracker transmits tracking data wirelessly from 
the tracker to the VIVE Focus 3 headset.  
 
VIVE Wrist Tracker can also be attached to a peripheral accessory for object tracking. When 
used for object tracking, VIVE Wrist Tracker transmits tracking data just as it does when used 
to assist hand tracking. In addition, the accessory can also be connected to VIVE Wrist tracker 
through its USB interface to obtain additional data from the accessory, which can then transmit 
the additional data to VIVE Focus 3 along with the tracking data. 
 

Use cases 

 
There are three use cases for VIVE Wrist Tracker. 
 
Use case 1: VIVE Wrist Tracker is attached to the wrist to assist hand tracking in VR. In this 
scenario, VIVE Wrist Tracker is paired wirelessly with VIVE Focus 3 to transmit tracking data. 

 

 
 

Figure: Use case 1 
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Use case 2: VIVE Wrist Tracker is attached to an accessory for object tracking. As with the 
first use case, in this scenario, VIVE Wrist Tracker is paired wirelessly with VIVE Focus 3 to 
transmit tracking data. 

 

 
 

Figure: Use case 2 
 
 
Use case 3: VIVE Wrist Tracker is attached to an accessory for object tracking. In addition, in 
this scenario, the accessory is also connected to VIVE Wrist Tracker via USB, allowing the 
accessory to send additional data to VIVE Wrist Tracker, which can then transmit the additional 
data to VIVE Focus 3 along with the tracking data. 

 

 
 

Figure: Use case 3 
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Hardware requirements 
 
This section describes the hardware requirements for accessories used with VIVE Wrist 
Tracker.  
 
Accessories must meet specific requirements to ensure that VIVE Wrist Tracker can generate 
accurate tracking data for the accessory and to ensure that any additional data provided by the 
accessory is compatible with VIVE Focus 3. 

 
Interface  

1. USB Type-C port: USB 2.0 Full-Speed (client) 
2. Buttons: 

• Power button: Powers the tracker on and off 

• App button: Defined by developer 
 

Radio frequency (RF)  

To ensure the stability of the wireless connection between VIVE Wrist Tracker and VIVE Focus 
3, the OTA performance of the tracker must not degrade by more than 3 dB an accessory is 
attached. 

Please adhere to the following recommendations to maximize RF performance. 

 

Figure: Spherical radius of the tracker antenna. Metal parts in this area may cause RF 

interference. (Spherical radius = 30 mm, with the center being the antenna feed point.) 
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For optimal OTA performance, the tracker antenna should be at least 30 mm away from 

any metal parts. 

 

Power  

• USB Type-C port voltage requirement: 5V+/-5%; > 200 mA 

• Maximum required charging time: 2 hours  

 

Optics  

VIVE Wrist Tracker has an asymmetrical shape. Therefore, its FOV is also asymmetrical. In 
addition, VIVE Focus 3 uses inside-out tracking, so the FOV of the tracker depends on the 
position of the headset relative to the orientation of the tracker. The following figures illustrate 
the FOV of VIVE Wrist Tracker in relation to VIVE Focus 3 when the headset is about 50 cm 
away from the tracker’s geometric center. 

 
 

Figure: Tracker FOV relative to headset position along the sagittal plane 
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Figure: Tracker FOV relative to headset position along the transverse plane 

 
The headset must stay within the FOV of the tracker during operation. In addition, make 
sure there aren’t any objects between the tracker and the headset, as this will interfere with 
object detection. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

 



 

 

VIVE Wrist Tracker  
HTC Corporation 

Developer Guidelines 
v1.1 

2022/3/24 

 

6        HTC Confidential and Proprietary 

 

The following illustration shows the FOV of VIVE Wrist Tracker when attached to a VR 
gaming peripheral, in this case an imitation firearm. If the mounting base extends beyond 
the recommended placement area, the tracker’s FOV will be blocked by the body of the 
accessory. 
 

 
 

Figure: Mounting base extends beyond recommended placement area 

 
For optimal tracking performance, we recommend attaching the tracker to the accessory 
so that the Power button faces the headset.    
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To maintain optimal tracking performance, make sure the gray area illustrated in the 
following figure remains exposed during operation. Do not attach objects to it or cover it 
with any materials. 
 

 
 

Figure: Exposed area (gray) and contact area of VIVE Wrist Tracker when attached to an 

accessory (blue) 
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Mounting  

Adhere to the following guidelines to ensure your safety when using VIVE Wrist Tracker with 
an accessory. 
 

a. The specifications of the accessory’s mounting interface must match those of the 
mounting base attached to the tracker. 
 

b. The tracker should be easy to attach and detach with two hands (that is, with one 
hand holding the tracker and the other holding the accessory.) 

 
c. The user should not be at risk of physical harm while attaching or detaching the 

tracker. 
 

d. Attaching or detaching the tracker should not cause the user any discomfort. 
 

e. To prevent unintended damage to the tracker, the tracker should not come into 
contact with any external objects during operation. 
 

f. To ensure optimal tracking performance, the accessory or its components should not 
be in the tracker’s FOV. 
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Example mounting interfaces   
 
Attaching VIVE Wrist Tracker to VR peripherals is simple and straightforward. The following 
CAD drawings show examples of how VIVE Wrist Tracker can be mounted to accessories 
such as imitation gaming weapons and safety equipment. The imitation gaming firearms 
depicted are equipped with a Picatinny rail, which can be used as a mounting interface.  
 
VIVE Tracker can be mounted to a Picatinny rail using a rail mount–type mounting base. CAD 
drawings of the VIVE Tracker rail mount are available to developers. Contact us for more 
information. 
 
Imitation firearms (mounting interface: Picatinny rail) 
  

 
                                

 
 

Figure: Toy like gun with VIVE Wrist Tracker and rail mount-type mounting base 
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The following two figures show the schematics for the accessory mounting rail (Picatinny rail). 
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Imitation edged gaming weapons 
 
The mounting interface should be as close as possible to the grip area of an edged gaming 
weapon. The length of the gaming weapon should be defined in the VR program. 
 

 
 

 
 
Fire extinguisher 
 
When VIVE Wrist Tracker is attached directly to a grip, the tracker’s FOV must be free from your 
hands and other objects during operation. 
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Mechanical specifications  
 

The following specifications may be useful for determining the compatibility of VIVE Wrist 
Tracker with various accessories. 

 
 

Figure: VIVE Wrist Tracker 
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Dimensions and weight 

 

 
 

Figure: Front, side, and back views of VIVE Wrist Tracker 
 

 
The tracker measures 86.9 mm (L) × 45.0 mm (W) × 58.8mm (H) and weighs 48.1 g. 
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Components 
 
 

 
 
 

Figure: Components 
 

1. LED indicators: Indicate pairing status  
 

2. Power button: For powering the tracker on and off 
 

3. App button: Defined by content 
 

4. Mounting mechanism: 
4.1    Metal pin for fastening accessories 
4.2    Friction pad for preventing slippage between the tracker and an accessory 
 

5. USB-C port: For connecting the tracker to an accessory 
 

  

5. USB-C port 

3. App button 

1. LED indicators 

4.1 Metal pin 

4.1 Metal pin 

2. Power button 
4.2 Friction pad 
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Mounting base assembly  

The following drawing illustrates how to attach a mounting base to VIVE Wrist Tracker. CAD 
files for the mounting base are available to developers. Contact us for more information. 
 

  
 
 
 

Figure: Mounting base assembly 
 

 
Make sure to install the mounting base on VIVE Wrist Tracker before attaching the tracker to 
the mounting interface on the accessory. 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

Mounting base 

Metal pin screw 

Metal pin screw 

Metal pin 

Metal pin 
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Metal pin dimensions 
 
The following schematic shows the dimensions of the metal pins. (Unit: mm) 
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Software 
 

This section describes how software can be used to adapt accessories and develop content for 
VIVE Wrist Tracker.  
 
In addition to transmitting tracking data, the VIVE Wrist Tracker can transmit additional data to 
VIVE Focus 3 USB from an attached accessory through the tracker’s USB Type-C interface.  
 
Accessory makers can utilize this feature when adapting accessories for VIVE Wrist Tracker. 
For details on the data formats that can be transferred between an accessory and VIVE Wrist 
Tracker, see the Data Formats section. 
 
Content developers can also take advantage of this feature when designing VR content for 
accessories attached to VIVE Wrist Tracker. For details on the types of software applications 
that can be used for development, see the Accessory integration and Unity integration. 

 
 

Accessory integration 

This section provides information on position transformation between an accessory and VIVE 
Wrist Tracker. Content developers can determine the correct rotation and translation result of 
the content developed for the accessory in a game engine such as Unity. 
 
The local coordinate system of the accessory is assumed to be front-facing on the z-axis (left-
handed coordinate system) with VIVE Wrist Tracker attached to the accessory as illustrated 
below. The rotation degree and translation distance of an accessory in relation to VIVE Wrist 
Tracker are described in terms of roll, yaw, and pitch, as well as Dx, Dy, and Dz, respectively, 
during integration. 
 
After the center of an accessory has been determined during the design process, the rotation 
degree and translation distance can be measured according to the conditions of integration.  
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Figure: Example accessory integration of a toy like gun 

 

Pitch: Angle of rotation around the x-axis 
Yaw: Angle of rotation around the y-axis 
Roll: Angle of rotation around the z-axis 

 
Dx : Distance between the center of the accessory and tracker along the x-axis 
Dy : Distance between the center of the accessory and tracker along the y-axis 
Dz : Distance between the center of the accessory and tracker along the z-axis 

 
Content developers can use these parameters to transform the tracker pose into an accessory 
pose with the following equations: 
 
Assuming the tracker rotation matrix is R𝑇𝑟𝑎𝑐𝑘𝑒𝑟, the accessory rotation matrix is R𝐴𝑐𝑐𝑒𝑠𝑠𝑜𝑟𝑦 = 

R𝑃𝑖𝑡𝑐ℎ_𝑌𝑎𝑤_𝑅𝑜𝑙𝑙 ∗ R𝑇𝑟𝑎𝑐𝑘𝑒𝑟. 

 
For the accessory position, V𝐴𝑐𝑐𝑒𝑠𝑠𝑜𝑟𝑦= V𝑇𝑟𝑎𝑐𝑘𝑒𝑟+ R𝐴𝑐𝑐𝑒𝑠𝑠𝑜𝑟𝑦*Distance. 
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System requirements 

 
To test hardware accessories or VR content with VIVE Wrist Tracker, you’ll need a VIVE Focus 
3 in addition to the hardware and software required for your accessory or content. For more 
information, visit www.vive.com. 
 
For accessory makers: 

 
Hardware accessories designed to send additional data to VIVE Focus 3 through VIVE Wrist 
Tracker must support USB 2.0 Full-Speed as well as USB host and Human Interface Device 
(HID) specifications. 
 

 
 
 
 
 
 
 

Figure: USB data transfer architecture 

 
 

Data formats 

Hardware accessories must be able to send data to VIVE Wrist Tracker via the HID protocol. 
As an HID device, the hardware accessory will send the data to the tracker through a USB HID 
Feature Report, the tracker will use to interpret the data. The data transfer interval should be 
longer than 10 ms.  
 
To learn more about USB HID specifications, visit https://www.usb.org/hid.  
 
In addition, the VID/PID USB combination for VIVE Wrist Tracker is 0BB4/09EA. The 
accessory will use this ID combination to find the drivers for the USB device. 
 
The following code samples outline the USB command flow between the accessory and VIVE 
Wrist Tracker. The maximum data payload is 12 bytes. 
 
For VIVE Focus 3 content developers: 
 
SetFeature 0xB4 data format: 
[0xB4] [Data size N] [Raw Data 1] [Raw Data 2] …… [Raw Data N]  (Max N = 12) 
 
 
 

VIVE Wrist  
Tracker 

Device               Accessory Host 
USB data transfer 

http://www.htcvive.com/
https://www.usb.org/hid
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Code samples 
The following code samplescan be used to send the setFeature command to VIVE Wrist 
Tracker. However, your system must be able to reference the correct API in order to send the 
USB setFeature command. 
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For PC VR developers who work with VIVE Business Streaming: 
 

SetFeature 0xB4 data format: 

Byte Index Data Remark 

0 Tag Index 
Indicates the version of the data being sent out. In this version, 
the default value is zero. 

1 Button 

TRIGGER                        0x01 
BUMPER                         0x02 
MENU                              0x04 
STEAM                            0x08 
PAD                                 0x10 
PAD_FINGERDOWN      0x20 
Reserved                         0x40 
Reserved                         0x80 

2 
Pad X value 

-32768 to 32767 
BYTE 2 is LSB 3 

4 
Pad Y value 

-32768 to 32767 
BYTE 4 is LSB 5 

6 
Trigger Raw 

Value: 0 to 65535 
BYTE 6 is LSB 7 

8  Reserved 

9  Reserved 

10  Reserved 

11  Reserved 

 

Table: VIVE Wrist Tracker accessory for work with VIVE Business Streaming data format 
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Unity integration 

This section describes how to use the Unity game engine to integrate VIVE Wrist Tracker when 
developing VR content. 
 
First, you need to pair VIVE Wrist Tracker with VIVE Focus 3.  

 
After pairing, the input type icon on the VIVE Focus 3 system dashboard will indicate that VIVE 
Wrist Tracker is connected. 

 

 
 

Figure: VIVE Wrist Tracker is added in VIVE Focus 3 
 
We recommended using use Unity 2019.4.3 or later. You can download it at 
https://unity3d.com/get-unity/download. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

https://unity3d.com/get-unity/download
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Setting up Unity for content creation 

Perform the following steps to start creating content for VIVE Wrist Tracker in Unity. 
 

1. Configure your Build Settings. 

a. Go to File > Build Settings…, and then select Switch Platform. 
b. Select Android. 
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2. Configure your Project Settings. 
a. Go to Edit > Project Settings.  
b. Under XR Plug-in Management, click the Android tab.  
c. Under Plug-in Providers, select Wave XR. 

 

 
 

d. Under Wave XR > Essence, click Import Feature - Tracker Model. 
 

 
 

e. Under Player > Other Settings > Identification, set the API level. 
 

 
 

3. Add AndroidManifest.xml to your configuration. 
a. Go to Wave > HandTracking and confirm that EnableHandTracking is selected.  

This setting will modify AndroidManifest.xml. 
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b. Wave > Tracker and confirm that EnableTracker is selected. 
This setting will also modify AndroidManifest.xml. 

 

 
 
Note: If you’re using a custom AndroidManifest.xml file and the file could not be configured, 
you’ll need to add the following configurations manually: 
 
<uses-feature android:name="wave.feature.tracker" android:required="true" /> 
<uses-feature android:name="wave.feature.handtracking" android:required="true" /> 
 

4. Enable scripts for your scene. 
a. Go to Assets > Wave > Essence > Tracker > Model > 4.2.90-preview.2 > Demo > 

Bracelet. 
b. Make sure Hand Manager (Script) and Tracker Manager (Script) are selected for 

the HandManager object. 
 

 
Note: If you need to use hand tracking or the tracker for your scene, you’ll need to add the 
Hand Manager and Tracker Manager scripts manually. 
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5. Build the Android APK. 
a. Go to Edit > Project Settings > Player, set the Product Name and Other Settings 

> Identification > Override Default Package Name > Package Name. 
 

  
 

 
 
 
 

b. Under File > Build Settings, click Build. 
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Configuring the VIVE Input Utility (VIU) 

Perform the following steps to configure the VIVE Input Utility (VIU) plugin for your project. 
 

1. Configure VIU settings. 
a. Go to Edit > Preferences, and then click Add Wave XR Plugin. 

 
Note: If the platform is not set to Android, click Switch Platform. 
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b. Select Wave XR. 
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c. Select Update Wave XR Plugin Native. 
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Note: Make sure both Enable Wave Hand Tracking Support and Enable Wave Tracker 
Support are selected. 
 

 
 

2. Configure your scene. 
a. Go to File > New Scene. 
b. Add the ViveCameraRig prefab to your scene, and then remove Main Camera. 

ViveCameraRig will be added to Assets\HTC.UnityPlugin\ViveInputUtility\Prefabs. 
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Your hands and the wrist trackers will now be visible in VR. 
 
Note: The default hand and tracker VR models for VIU will appear white. 
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FAQs  
 

Type No. Question Answer 

General 1 How do I check the tracker’s battery 
level? 

When in VR, you can check the tracker’s battery level 
from the Lobby or the VIVE Menu. When the battery is 
low, a flashing red dot will appear next to the tracker 
icon. 

2 How do I pair VIVE Wrist Tracker 
with VIVE Focus 3? 

To pair VIVE Wrist Tracker, go to Settings > 
Connectivity > Controller, and select the input type 
icon in the upper right. Follow the on-screen 
instructions to pair the wrist trackers. 

3 What does the status LED on VIVE 
Wrist Tracker mean? 

The status LEDs indicate the status of the tracker and 
which side it’s paired on. 
 

• Solid green: Tracker is paired 

• Blinking red: Battery is low 

• Blinking blue: Tracker being paired with the 
headset 

• Solid blue: The tracker is connecting to the 
headset 

• Solid orange: Charging 

   

4 How do I update VIVE Wrist 
Tracker? 

If a firmware update for VIVE Wrist Tracker is 
available, the Update firmware button will appear on 
the Controller screen. Select the button to start the 
firmware update. 
 
Note: Do not power off the tracker before the firmware 
update is finished. Doing so could result in a firmware 
error. 

5 Why does VIVE Wrist Tracker 
automatically turn off? 

VIVE Wrist Tracker automatically turns off when the 
battery is drained or when the headset enters Standby 
mode or powers off. 

6 Why can't I switch to VIVE Wrist 
Tracker in VIVE Focus 3? 

If you can’t see the input type button in the upper right 
of the Controller screen, check that your VIVE Focus 
3 is updated to the latest version. 
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Type No. Question Answer 

SDK 1 Where can I download the latest 
VIVE Wave SDK and support 
documentation? 

You can download the VIVE Wave SDK at 
https://developer.vive.com/resources/vive-
wave/download/latest/. 
VIVE Wave SDK support documentation is available at 
https://hub.vive.com/storage/app/doc/en-

us/UnityXR/UnityXRTutorials.html. 
2 How can I use VIVE Wrist Tracker 

with content created for the VIVE 
Focus 3 controller?  

You or a content developer will need to apply new 
coordinate settings to VIVE Wrist Tracker according to 
the original coordinate settings of the controllers. 
 
If the coordinate settings are different, VIVE Wrist 
Tracker will need to be recalibrated. 

3 Do the VIVE Wrist Tracker 
hardware buttons correspond to any 
VIVE Focus 3 controller buttons? 

The Power button corresponds to the VIVE/Menu 
buttons, and the App button corresponds to the A/X 
buttons. 

  
  

Type No. Question Answer 

Hardware 1 What is included in the VIVE Wrist 
Tracker CAD files?  

The compressed CAD file package contains STP files 
for VIVE Wrist Tracker, Rail mount, and Mounting 
base. You can use these files for reference when 
designing hardware accessories for VIVE Wrist 
Tracker.  
 
Download the CAD file from below links: 
 
VIVE Wrist Tracker surface CAD: 

https://dl.vive.com/3d-

files/vive_wrister_tracker_surface_3d.zip 
 
Rail mount CAD: 

https://dl.vive.com/3d-

files/vive_wrister_tracker_picatinny_rail_mount_3d.zi

p 
 
Mounting base CAD: 

https://dl.vive.com/3d-

files/vive_wrister_tracker_mounting_base_3d.zip 
 
 

 
 
 
 
  

https://developer.vive.com/resources/vive-wave/download/latest/
https://developer.vive.com/resources/vive-wave/download/latest/
https://hub.vive.com/storage/app/doc/en-us/UnityXR/UnityXRTutorials.html
https://hub.vive.com/storage/app/doc/en-us/UnityXR/UnityXRTutorials.html
https://dl.vive.com/3d-files/vive_wrister_tracker_surface_3d.zip
https://dl.vive.com/3d-files/vive_wrister_tracker_surface_3d.zip
https://dl.vive.com/3d-files/vive_wrister_tracker_picatinny_rail_mount_3d.zip
https://dl.vive.com/3d-files/vive_wrister_tracker_picatinny_rail_mount_3d.zip
https://dl.vive.com/3d-files/vive_wrister_tracker_picatinny_rail_mount_3d.zip
https://dl.vive.com/3d-files/vive_wrister_tracker_mounting_base_3d.zip
https://dl.vive.com/3d-files/vive_wrister_tracker_mounting_base_3d.zip

