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Prerequisites 
The SRanipal SDK for Unreal can be implemented only when the SRanipal SDK has been setup. If not, 

follow the following guideline to setup the SRanipal SDK — SRanipal_version\SRanipal_SDK_Guide.pdf. 

Create a new project and add the SDK 
1. Open Unreal Engine and create a new C++ project. 

2. Unzip the plugins at SRanipal_version\03_Unreal\Vive-SRanipal-Unreal-Plugin.zip 

3. Copy the folder Plugins inside the folder you unzip above into your project. 

4. Restart the editor and enable SRanipal in Settings > Plugins. 

 

Play the sample level 
1. In the Unreal content browser, you can find the sample level in: 

SRanipal Content/Level/LipSample. 

2. Ensure that all Requirements mentioned in SRanipal_SDK_Guide.docx are met and then click 

VR_Preview. 

 

Package the sample app 
1. In Edit > Project Settings choose Maps & Modes  

2. Change the Game Default Map to LipSample. 

 
3. In Edit > Project Settings choose Description (Or you can search “vr”). 

4. Enable Start in VR. 

 
5. Select File > Package Project > Windows > Windows (64-bit). 

 



Copyright 2020 HTC Vive SRanipal SDK   Release version: 1.3.3.0 

Enable SRanipal functionality in your Unreal project. 
# NOTE that the Enable SRanipal functionality step has been changed after SRanipal v1.3.0.9. 

Enable the SRanipal Framework (You should ignore this step if you are using SRanipal 

version after 1.3.0.9.) 
1. You can find the actor: SRanipal_Lip_Framework under: SRanipal C++ Classes/SRanipal/Public 

2. Put the framework actor in your level. 

3. Toggle “Enable Lip” in the actor’s Details Panel to enable the lip-tracking feature of the SRanipal 

SDK. 

4. Explore the Lip features. 

Enable the SRanipal Framework in SRanipal v1.3.3.0 
# In SRanipal v1.3.3.0, Lip Tracking is disabled by default. 

 If you want to use Lip tracking in Editor, you need to tick the box “Enable Lip by Default” in 

Project Settings -> Plugins -> SRanipal of your UE4 project. 
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 If you want to use Lip tracking in a Package Build, you can 1. Tick the box “Enable Lip by Default” 

in Project Settings -> Plugins -> SRanipal or 2. Call the “Start Lip Framework” function. 

1. 

 
 
2. 
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Lip relative features 

Control Avatar’ lip 
To reflect the player’s lip movement on an avatar, refer to the actor SRanipal_AvatarLipSample in 

SRanipal C++ Classes/SRanipal/Public 
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SRanipal Compatible Avatar 

Overview 
Through SRanipal’s lip-tracking features, an avatar’s morph targets values can be animated with the 

player’s lip movement. A compatible avatar for SRanipal has 26 blendshapes in version 1 and 38 

blendshapes (37 + 1 no detect) in version 2 for lip tracking.  Demonstrated in this section. 

(Note that the development will focus on version 2, version 1 will still support the system but 

will not be updated in the future.) 

Note: Blendshape name with prefix annotation “*” means that it is composed of multiple 

blendshapes. 

 

Sample Avatar 
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Jaw, Mouth and Cheek BlendShapes – version 2 

Jaw_Right 

 

Description 

This blendShape moves the jaw further rightward with a 
higher value. 

 

Jaw_Forward 

 

Description 

This blendShape moves the jaw further forward with a higher 
value. 

 

Jaw_Open 

 

Description 

This blendShape opens the mouth further with the higher 
value. 

 

 

 

Jaw_Left 

 

Description 

This blendShape moves the jaw further leftward with a higher 
value. 
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Mouth_Ape_Shape 

 

Description 

This blendShape stretches the jaw further with a higher 
value. 

 

Mouth_Upper_Right 

 

Description 

This blendShape move your upper lip rightward. 

 

Mouth_Upper_Left 

 

Description 

This blendShape move your upper lip leftward. 

 

Mouth_Lower_Right 

 

Description 

This blendShape moves the lower lip further rightward with a 
higher value.  
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Mouth_Lower_Left 

 

Description 

This blendShape moves the lower lip further leftward with a 
higher value.  

 

 

*Mouth_Upper_Overturn 

 

Description 

This blendShape pout your upper lip. 
Must be used with UpperRight_Up and UpperLeft_Up to 
complete Upper O mouth. 

 
 

 

 

*Mouth_Lower_Overturn 

 

Description 

This blendShape pout your lower lip 
Must be used with LowerRight_Down and UpperLeft_Up to 
complete Lower O mouth. 
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Mouth_Pout 

 

Description 

This blendShape allows the lips to pout more with a higher 
value. 

 

Mouth_Upper_Overturn + Mouth_Lower_Overturn +  Lip Up and down (Note that we did 
not provide this as independent blendShape) 

  

 

Description 

The entire O-shaped mouth is formed by the combination of 6 
blendshapes: 
Mouth_Upper_Overturn Mouth_Lower_Overturn  
Mouth_UpperLeft_Up 
Mouth_UpperRight_Up 
Mouth_LowerLeft_Down 
Mouth_LowerRight_Down 

 

Mouth_Smile_Right 

 

Description 

This blendShape raises the right side of the mouth further 
with a higher value. 

 

 

 

 

 

 



Copyright 2020 HTC Vive SRanipal SDK   Release version: 1.3.3.0 

Mouth_Smile_Left 

 

Description 

This blendShape raises the left side of the mouth further with 
a higher value. 

 

Mouth_Sad_Right 

 

Description 

This blendShape lowers the right side of the mouth further 
with a higher value. 

 

Mouth_Sad_Left 

 

Description 

This blendShape lowers the left side of the mouth further 
with a higher value.  

 

Cheek_Puff_Right 

 

Description 

This blendShape puffs up the right side of the cheek further 
with a higher value. 
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Cheek_Puff_Left 

 

Description 

This blendShape puffs up the left side of the cheek further 
with a higher value.  

 

Cheek_Suck 

 

Description 

This blendShape sucks in the cheeks on both sides further 
with a higher value.  

 

Mouth_Upper_UpRight 

 

Description 

This blendShape raises the right upper lip further with a higher 
value.  

 

Mouth_Upper_ UpLeft 

 

Description 

This blendShape lowers the left upper lip further with a higher 
value.  
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Mouth_Lower_DownRight 

 

Description 

This blendShape lowers the right lower lip further with a 
higher value.  

 

Mouth_Lower_DownLeft 

 

Description 

This blendShape lowers the left lower lip further with a higher 
value.  

 

Mouth_Upper_Inside 

 

Description 

This blendShape rolls in the upper lip further with a higher 
value. 

 

Mouth_Lower_Inside 

 

Description 

This blendShape rolls in the lower lip further with a higher 
value.  
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Mouth_Lower_Overlay 

 

Description 

This blendShape stretches the lower lip further and lays it on 
the upper lip further with a higher value. 

 

Tongue_LongStep1 

 

Description 

This blendShape stick the tongue out slightly. 
 
In step1 of extending the tongue, the main action of the 
tongue is to lift up, and the elongated length only extends to a 
little bit beyond the teeth. 

 

Tongue_LongStep2 

 

Description 

This blendShape stick the tongue out extremely. 
 
Continuing the step1, extend the tongue to the longest. 
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*Tongue_Down 

 

  

Description 

This blendShape stick the tongue out and down extremely. 
 
This example contains (Tongue_Down 
+ Tongue_LongStep2 + Tongue_LongStep1) 
 

 

*Tongue_Up 

  

 

Description 

This blendShape stick the tongue out and up extremely. 
 
This example contains (Tongue_Up 
+ Tongue_LongStep2 + Tongue_LongStep1) 
 

 

*Tongue_Right 

 

 

Description 

This blendShape stick the tongue out and right extremely. 
 
This example contains (Tongue_Right 
+ Tongue_LongStep2 + Tongue_LongStep1) 
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*Tongue_Left 

 

 
 

Description 

This blendShape stick the tongue out and left extremely. 
 
This example contains (Tongue_Left 
+ Tongue_LongStep2 + Tongue_LongStep1) 
 

 

*Tongue_Roll 

 

 

Description 

This blendShape stick the tongue out and Roll. 
 
This example contains (Tongue_Roll 
+ Tongue_LongStep2 + Tongue_LongStep1) 
 

 

 

 

 

 

 

 

 



Copyright 2020 HTC Vive SRanipal SDK   Release version: 1.3.3.0 

*Tongue_UpLeft_Morph 
Tongue_Left+Tongue_Up+ 
Tongue_LongStep2 + 
Tongue_LongStep1: 

 
Tongue_Left+Tongue_Up+ 
Tongue_LongStep2 + 
Tongue_LongStep1 
+ Tongue_UpLeft_Morph: 

 

Description 

This blendShape has no effect when it exist alone, it is used as 
a component of other blendShapes. 
When both the Left and Up (Tongue_Left+ 
Tongue_Up+ Tongue_LongStep2 + Tongue_LongStep1) 
Blendershape appear at the same time, the tongue will be 
deformed, add this blendShape to fix it. 

 

*Tongue_UpRight_Morph 
Tongue_Right + Tongue_Up+ 
Tongue_LongStep2 + 
Tongue_LongStep1: 

 
Tongue_Right + Tongue_Up+ 
Tongue_LongStep2 + 
Tongue_LongStep1 
+ Tongue_UpRight_Morph: 

 

Description 

This blendShape has no effect when it exist alone, it is used as 
a component of other blendShapes. 
When both the Right and Up (Tongue_Right+ 
Tongue_Up+ Tongue_LongStep2 + Tongue_LongStep1) 
Blendershape appear at the same time, the tongue will be 
deformed, add this blendShape to fix it. 
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*Tongue_DownLeft_Morph 
Tongue_Left+Tongue_Down+ 
Tongue_LongStep2 + 
Tongue_LongStep1: 

 
Tongue_Left+Tongue_Down+ 
Tongue_LongStep2 + 
Tongue_LongStep1+ 
Tongue_DownLeft_Morph: 

 

Description 

This blendShape has no effect when it exist alone, it is used as 
a component of other blendShapes. 
When both the Left and Down (Tongue_Left+ 
Tongue_Down+ Tongue_LongStep2 + Tongue_LongStep1) 
Blendershape appear at the same time, the tongue will be 
deformed, add this blendShape to fix it. 

 

*Tongue_DownRight_Morph 
Tongue_Right+Tongue_Down+ 
Tongue_LongStep2 + 
Tongue_LongStep1: 

 
Tongue_Right+Tongue_Down + 
Tongue_LongStep2 + 
Tongue_LongStep1  + 
Tongue_DownRight_Morph: 

 

Description 

This blendShape has no effect when it exist alone, it is used as 
a component of other blendShapes. 
When both the Right and Down (Tongue_Right+ 
Tongue_Down+ Tongue_LongStep2 + Tongue_LongStep1) 
Blendershape appear at the same time, the tongue will be 
deformed, add this blendShape to fix it. 
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Jaw, Mouth and Cheek Morph Target Examples – version 1 

Jaw_Forward 

 

Description 

This blendShape moves the jaw further forward with a higher 
value. 

 

Jaw_Right 

 

Description 

This blendShape moves the jaw further rightward with a 
higher value. 

 

Jaw_Left 

 

Description 

This blendShape moves the jaw further leftward with a higher 
value. 

 

Jaw_Open 

Description 
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This blendShape opens the mouth further with the higher 
value. 

 

Mouth_Ape_Shape 

 

Description 

This blendShape stretches the jaw further with a higher value. 

 

Mouth_O_Shape 

 

Description 

This blendShape allows the lips to form an “O” shape with a 
higher value. 

 

Mouth_Pout 

 

Description 

This blendShape allows the lips to pout more with a higher 
value. 
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Mouth_Lower_Right 

 

Description 

This blendShape moves the lower lip further rightward with a 
higher value.  

 

Mouth_Lower_Left 

 

Description 

This blendShape moves the lower lip further leftward with a 
higher value.  

 

Mouth_Smile_Right 

 

Description 

This blendShape raises the right side of the mouth further 
with a higher value. 

 

Mouth_Smile_Left 

Description 
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This blendShape raises the left side of the mouth further with 
a higher value. 

 

Mouth_Sad_Right 

 

Description 

This blendShape lowers the right side of the mouth further 
with a higher value.  

 

Mouth_Sad_Left 

 

Description 

This blendShape lowers the left side of the mouth further 
with a higher value.  

 

Cheek_Puff_Right 

 

Description 

This blendShape puffs up the right side of the cheek further 
with a higher value. 
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Cheek_Puff_Left 

 

Description 

This blendShape puffs up the left side of the cheek further 
with a higher value.  

 

Mouth_Lower_Inside 

 

Description 

This blendShape rolls in the lower lip further with a higher 
value.  

 

Mouth_Upper_Inside 

 

Description 

This blendShape rolls in the upper lip further with a higher 
value. 

 

Mouth_Lower_Overlay 

Description 
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This blendShape stretches the lower lip further and lays it on 
the upper lip further with a higher value. 

 

Mouth_Upper_Overlay 

 

Description 

This blendShape stretches the upper lip further and lays it on 
lower lip further with a higher value. 

 

Cheek_Suck 

 

Description 

This blendShape sucks in the cheeks on both sides further 
with a higher value.  

 

Mouth_LowerRight_Down 

 

Description 

This blendShape lowers the right lower lip further with a 
higher value.  
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Mouth_LowerLeft_Down 

 

Description 

This blendShape lowers the left lower lip further with a higher 
value.  

Mouth_UpperRight_Up 

 

Description 

This blendShape raises the right upper lip further with a 
higher value.  

 

Mouth_UpperLeft_Up 

 

Description 

This blendShape lowers the left upper lip further with a higher 
value.  

 

Mouth_Philtrum_Right 

 

Description 

This blendShape moves the philtrum further rightward with a 
higher value.  
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Mouth_Philtrum_Left 

 

Description 

This blendShape moves the philtrum further leftward with a 
higher value.  

 

 


